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A Digispark is a tiny
microcontroller board
(similar to an Arduino)
that can connect to a
computer's USB port
and pretend to be a
mouse or keyboard.

This zine will teach you to program a Digispark mouse jiggler using
the Arduino programming language. When you plug your Digispark
clone into a computer's USB port, it will quietly jiggle the mouse
cursor to prevent the computer from going to sleep. You'll also
learn to program a keyboard simulator, which can type any
sequence of keys you want.

The Digispark is built around the ATtiny85, a microcontroller chip
developed by the company Atmel (based in San Jose, CA and
acquired by Microchip Technology in 2016). The ATtiny85 has 8 KB
of flash memory and a clock speed of 20 MHz.

To make the ATtiny85 chip easier to use for DIY projects, the
company Digistump (based in Portland, OR) created the Digispark.
They don't sell Digispark boards anymore, but it's easy to find
cheap clones based on their designs. This tutorial uses a Digispark
Rev.3 clone that looks like this:




The Digispark has a built-in USB interface, a 500mA 5V regulator, 6
I/0 Pins, and 8KB of flash memory (~6KB available after writing the
USB bootloader). It has two LEDs: a green one for power, and a red
one you can control using code. You'll program your Digispark
clone using the Arduino IDE (integrated development
environment).

This tutorial includes instructions for macOS, Windows and
Ubuntu. (With macOS, your computer might not recognize the
Digispark as a USB mouse every time you plug it in. Unplug and
plug it back in a few times, and it should work.)

Note: If you're using a Digispark clone that doesn't have a USB
bootloader installed, read the appendix first to learn how to
burn Micronucleus to your device.

_, Install the Arduino IDE (Ubuntu and
similar)

The Arduino IDE (integrated development environment) is the
application you'll use to program your Digispark clone.

Installation method 1: Snap package manager

Open a terminal window and run the following command to install
the Arduino IDE using the Snap package manager. You'll need to
enter your password, and it will take a few minutes to install.

sudo snap install arduino

Now run the following command to add your username to the
dialout group. This will let you program the board via USB.

sudo usermod -a -G dialout S$USER
Restart your computer.

Open a terminal window and run the command arduino to start
the Arduino IDE.



Note: The pinout diagram below is for the pins on the USBASP
device, without the ribbon wire attached.
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Once the wires are connected, plug the USBASP into your
computer's USB port. A green light on your Digispark clone will turn
on.

Run the following command to flash the Micronucleus firmware to
your Digispark. (Replace line breaks with spaces.)

avrdude -c USBasp -p attiny85 -U lfuse:w:0xel:m
-U hfuse:w:0xdd:m -U efuse:w:0xfe:m -B 20
/<add path here>/t85 default.hex

If you're successful, you'll see a confirmation in the terminal.
Disconnect the USBASP from your USB port, then disconnect the
wires from the Digispark. Now you can program your Digispark
clone from the Arduino IDE!

Installation method 2: APT package manager

Depending on the version of Ubuntu you're using, you may be able
to install Arduino using the APT package manager. Simply type the
following command in a terminal window and press enter. You'll
need to enter your password, and it will take a few minutes to
install.

sudo apt-get install arduino

Now run the following command to add your username to the
dialout group. This will let you program the board via USB.

sudo usermod -a -G dialout S$USER
Run the command arduino to start the Arduino IDE.
Installation meth : Installer Scri

Go to the following URL and follow the steps to install the Arduino
IDE using the installer script from https://arduino.cc:

_] Install the Arduino IDE (macOS)

If you're using macOS, you'll need version 2.0 of the Arduino IDE,
which is currently in beta. To download it, go to the following URL
and click MacOS.

https://www.arduino.cc/en/software#experimental-software

Open the .dmg file you just downloaded and drag the Arduino IDE
application file to your Applications folder.



_, Install the Arduino IDE (Windows)

Go to the following URL and download the Arduino IDE for
Windows. Follow the instructions to install it on your machine.

https://www.arduino.cc/en/software

Next, go to the following URL (all one line) to download the
Digistump driver. Follow the provided installation instructions.

https-//githut . . i

wnl /1.6.7/Digistump.Drivers.zi

_I Install Digistump software package

When you open the Arduino IDE, you'll see a window that looks like
the one below. Before you write any code, you'll need to install a
package with the software required to program your Digispark
clone.

sketch_dec01a | Arduino 1.8.14 Hourly Build 2021/04/0... - 0O X

Eile Edit sketch TIools Help

sketch_decOla
vold setup() {
£/ put your setup code here, to run once:

¥

vold loop() {
A4 put your main code here, to run repeatedly:

Arduing Uno

¥

If you want to install a bootloader on your Digispark clone, this
how-to guide is a good place to start:

https://asdasd.page/2021/Program-Bootloader-of-Digispark-ATTiny
85-with-A-ISP-Programmer/

Here's a brief summary of what you'll need to do:

First, run the following command to download the Micronucleus
bootloader firmware for the ATtiny85:

git clone https://github.com/micronucleus/micronucleus.git

Next you'll install the command-line program avrdude. On Ubuntu
(or similar), you can use the command sudo apt-get install
avrdude.

On macOS you can use brew install avrdude. (You'll need to
install the Homebrew package manager first: https://brew.sh.)

If you're using Windows, go to the following URL and follow the
instructions to install WinAVR:

http://www.ladyada.net/learn/avr/setup-win.html

Now you'll use wires to connect the pins on your USBASP to the
pins on your Digispark clone. Here are the connections you'll need
to make:

- MOSI (Pin1) from the programmer to MOSI (PBO) on the
board

- MISO (Pin9) from the programmer to MISO (PB1) on the
board

- RES (Pin5) from the programmer to RESET (PB5) on the
board

- SCK (Pin7) from the programmer to SCK (PB2) on the board

- VCC (VTG Pin2) from the programmer to VCC on the board

- GND (Pin4,6,8,10) from the programmer to GND on the
board



_l More Digispark resources In the menu bar, select File > Preferences. (Or Arduino >
Preferences on macOS.)

e Official Digispark wiki

httQS//dlngtquCom/WlkI/dIgISQa rk sketch_deco01a | Arduino 1.8.14 Hourly Build 2021
File Edit Sketch Tools Help
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_] Appendix: Burn Micronucleus bootloader to a Add the following URL (without the line break) to the list of
Digispark using USBASP programmer Additional Boards Manager URLs, then click OK.
If you're using a plain Digispark clone that doesn't have a https://raw.githubusercontent.com/Arminjo/DigistumpArduino/
bootloader, you'll need to flash one to the device before you master/package digistump indexjson
program it with the Arduino IDE. Since a bootloader is required to LA P
start a USB connection, you won't be able to flash the bootloader Use accessibility Features

Additional Boards Manager URLs: | m/ArminJo/DigistumpArduine/master/package_digistump_index json fim]

over USB. Instead, you'll use a USB-ISP (in-system programmer)
dEVICG SUCh as the USBASP (beIOW). YOU can ﬂnd one On“ne fOF fhome/iffyfsnap/arduino/61/.arduinat 5/preferences.txt
around $1 0 (edit only when Arduino is not running)

iore preferences can be edited directlyin the file

OK Cancel

Close and relaunch the Arduino IDE.




In the menu bar, go to Tools > Board > Boards Manager....

| Arduino 1.8.14 Hourly Build 2021/04/0... - O &
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_] Completely reset the Arduino IDE

If something goes wrong with the Arduino IDE, you may need to
reset its packages and settings. First, quit the application.

On Linux, run the following command to delete the directory that

contains the Arduino IDE's packages and settings:

Arduine Nano

- - Board: "Arduino Uno" »
w Port , Arduine Mega or Mega 2560
Get Board Info Arduine Mega ADK rm - rf ~/ . ard'LIanl 5/
Programmer: "AVRISP mkil" » Arduine Lecnarde
Bum Bootloader pividwilnial ' ) _ )
| ot If you're using macOS, open Terminal and run the following

command instead:
In the search box at the top of the Boards Manager window, type
"digistump." Look for the package called Digistump AVR Boards
and click Install. Installation will take a minute or so.

rm -rf ~/Library/Arduinol5/

On Windows, open PowerShell and run the following command:

Boards Manager

rd /s /q C:\Users\{username}\AppData\Local\Arduinol5

Type | All ~ | digistump

in this package:
-16.5mhz), Digispark Pro (Defauit 16 Mha), Digispark Pro (16 Mhz) (32 byte buffer), Digispark Pro (16 Mhz) (64 byte buffer),
No USB), Digispark (8mhz - No USB), Digispark (1mhz - No USB).

_] View connected USB devices

Install
3

If you're using Ubuntu (or similar), open a terminal window and run
the following command to see a list of connected USB devices:

You may need to click Install again to get the latest version of the

. lsusb
package (version 1.7.5 as of December 2021).

) ) ) On macQOS, open Terminal and use this command:
Click Close to exit the Boards Manager window.

system profiler SPUSBDataType

In the menu bar, go to Tools > Board > Digistump AVR Boards
and select Digispark. If you're using Windows 10 or higher, open PowerShell and run the

following command to view connected USB devices.
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pnputil /enum-devices | findstr USB

void setup
7 put your s Manage Libraries. CrrlShift+!
) Serial Monitor CtrlShift+h
Serial Plotter Cerleshife+l
void Loop() {
// put your m WiFi101 /WiFININA Firmware Updater
Clock: "16.5 MHz - For V-UsB" > ArdunoAVRBoards  »
Micronucleus variant: "Default (6650 bytes avail.)" >
Burn Bootloader Method: "Upgrade (viaUSB)" > Digispark Pro (16 MHz)
Port >




_, Random string generator

This program types a pseudorandom series of letters and
numbers. The function randomSeed (analogRead (5) ) uses
random noise from pin 5 to seed the random number generator.

#include <DigiKeyboard.h>

void setup () {
// Seed pseudorandom generator using noise from pin 5
randomSeed (analogRead (5)) ;

}

void loop () {
//Choose a random key code
unsigned int char number = random(4, 40);

//Type key
DigiKeyboard.sendKeyStroke (char number) ;

// Pause for 0.1 second
DigiKeyboard.delay (100) ;

_, Save and close everything

The code below presses Ctrl+S and Ctrl+W repeatedly.

#include <DigiKeyboard.h>
void setup () {}

void loop () {
// Pause for 1.5 seconds
DigiKeyboard.delay (1500) ;

// Press Ctrl+S (or command+S for macOS)
DigiKeyboard.sendKeyStroke (KEY S, MOD CONTROL LEFT) ;
//DigiKeyboard.sendKeyStroke (KEY S, MOD GUI_ LEFT) ;

// Pause for 1.5 seconds
DigiKeyboard.delay (1500) ;

// Press Ctrl+W (or command+W for macOS)
DigiKeyboard.sendKeyStroke (KEY W, MOD CONTROL LEFT) ;
//DigiKeyboard.sendKeyStroke (KEY W, MOD GUI LEFT);

Under Tools > Clock in the menu bar, select 16.5 MHz - for V-USB.

sketch_deco3a | Arduino 1.8.15

g ‘ Auto Format CtrlsT
Archive Sketch
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Board; "Digispark” >

I 16 MHz - No USB
Micronucleus variant: "Default (6650 bytes avall.)" >
Burn Bootloader Method: "Upgrade (via USB)" > ()8MHz-NoUSB
Port > 1 MHz - No USB

Get Board Info

Finally, go to Tools > Programmer and select micronucleus.2.5.

You're now ready to program your Digispark clone. Nice work!

~ ] Make the LED blink

As a test, let's make the red LED on your Digispark blink on and off.
Type out the example code in the Arduino IDE, or download it from
the following URL:

https://iffybooks.net/mousejiggler

#include <DigiMouse.h>

void setup () {
pinMode (1, OUTPUT) ;
DigiMouse.begin () ;

void loop () {
digitalWrite(l, HIGH) ;
DigiMouse.delay (1000) ;
digitalWrite (1, LOW) ;
DigiMouse.delay (1000) ;

The first line of code, #include <DigiMouse.h>, imports the mouse
software you'll use.



When you plug your Digispark clone into a computer's USB port, it
will automatically run a function called setup (), then a function

_] Some useful DigiKeyboard functions

called 1oop (). In the example code, setup () has two lines of — .
code: DigiKeyboard.print ("Hello!") Types the characters "Hello!"
(without quotation marks)

1. The function pinMode (1, OUTPUT) sets pin 1 to accept

DigiKeyboard.sendKeyStroke (KEY_ S, Presses Ctrl + S
output. Pin 1 controls the red LED. MOD_CONTROL_LEFT) ; (Windows/Linux shortcut)
2. The DigiMouse.begin () function initializes the mouse
DigiKeyboard.sendKeyStroke (KEY S, +
software. MOD GUT LEET) Presses Command + S (macQOS
- = shortcut)
The loop () function runs next, executing the same four lines of DigiKeyboard.sendKeyStroke (KEY_ENTER) ; Presses enter
code infinitely:
DigiKeyboard.sendKeyStroke (KEY SPACE) ; Presses the space bar
1. Thefunction digitalWrite (1, HIGH) turnsthered LED
on DigiKeyboard.sendKeyStroke (random (4, Presses a random letter or
. 40)) ;
2. The function DigiMouse.delay (1000) pauses for 1 number
second. Y f h lete list of k d d inth
3. ThefunctiondigitalWrite (1, LOW) turnsthered LED 'ou c.ar'1 reference the cqmp ete list 9 €y codes an _names In the
off file DigiKeyboard.h, which you can find at the following URL:

4. The function DigiMouse.delay (1000) pauses for 1

https://github.com/digistump/DigisparkArduinolntegration/blob/
second.

master/libraries/DigisparkKeyboard/DigiKeyboard.h

If you've written code in C, C++, or Java, the syntax of the Arduino
programming language will look familiar. Curly brackets ({}) are
used to enclose code inside loops and function definitions. After
each code statement, you'll need to use a semicolon (;).
Whitespace (spaces, tabs, line breaks) doesn't affect your code.

Functions, such as DigiMouse.delay (1000) or
digitalWrite (1, HIGH), can accept one or more arguments
(i.e., input values) in the parentheses following the function name.



_l Program a keyboard simulator

In addition to simulating a mouse, your Digispark clone can

pretend to be a keyboard. The code below types the sentence "This

is a test!", then presses enter and pauses for 500 milliseconds, or
0.5 seconds.

#include <DigiKeyboard.h>
void setup () {}

// Infinite loop

void loop () {
DigiKeyboard.sendKeyStroke (0) ;
DigiKeyboard.delay (500) ;
DigiKeyboard.print ("This is a test!");
DigiKeyboard.sendKeyStroke (KEY ENTER) ;

Including the function DigiKeyboard.sendKeyStroke (0) at the
beginning of the loop isn't required, but it helps ensure the first
real keystroke doesn't get cut off.

The example code below types "https://iffybooks.net", then presses

enter. Then a for loop at the end runs infinitely, which effectively
disconnects the device.

#include <DigiKeyboard.h>

void setup () {
pinMode (1, OUTPUT); //LED on Model A

}

// Continued on the next page ..

void loop () {
DigiKeyboard.sendKeyStroke (0) ;
DigiKeyboard.delay (500) ;
DigiKeyboard.print ("https://iffybooks.net");
DigiKeyboard.sendKeyStroke (KEY ENTER) ;
for(;;){/*Infinite loop to disconnect device*/}

Click the Verify icon to compile your code. You'll be prompted to
save your project first.

Eile Edit Sketch Tools Help
20 BEE -~

sketch _decOla §

If your code compiled successfully, you'll see a message like this:

Digispark (Default - 168,5mhz)

Make sure your Digispark is disconnected from your computer.
Then click the Upload icon at the top of the Arduino IDE.

File Edit Sketch Tools Help

sketch_decOla

At the bottom of the Arduino IDE window, you'll see a message that

says "Plug in device now... (will timeout in 60 seconds)."

Digispark (Default - 16.5mhz)




Plug your Digispark into a USB port on your computer and wait a .
§ your “igisp port on your comp , | Program a random clicker
few moments for your code to upload. If it's a success, you'll see
"upload complete" in the console. The program below moves the mouse cursor -250 to 250 pixels in
each direction, with the distance selected at random. This one

writing: 70% complete works well for clicking around on Wikipedia.
writing: 75% complete

writing: B8@% complete

> Starting the user app ...
running: 100% complete

>> Micronucleus done. Thank you! void setup () {
pinMode (1, OUTPUT) ;
DigiMouse.begin () ;

#include <DigiMouse.h>

upload complete.

// Turn on LED for 0.25 seconds
digitalWrite (1, HIGH) ;

When the upload is done, the red light on the board should start DigiMouse.delay (250) ;

blinking on and off. digitalWrite (1, LOW);

}

Disconnect the Digispark from your computer and plug it back in. It

should start blinking again. Pretty neat! vod il oop (i
// Choose x and y values from -250 to 250
unsigned int random x = 250 - random(501);
_, Program a basic mouse jiggler unsigned int random y = 250 - random(501);
The example code below will move the mouse cursor in a 20-pixel DigiMouse.move (random x, random y, O0);
squareeveQ/Zseconds. DigiMouse.delay(SOO);_ B
DigiMouse.leftClick() ;
First, the setup () function runs two lines of code: DigiMouse.delay (10);
pinMode (1, OUTPUT) sets up pin 1 for output, which lets you DigiMouse.setButtons (0);

T DigiM .del d 5000 8
control the red LED. Next, DigiMouse .begin () initializes the igiMouse.delay (random( )

DigiMouse software.

When the loop () function runs, the code within will repeat
infinitely. First, DigiMouse .delay (2000) pauses for 2000
milliseconds, or 2 seconds. Next, DigiMouse .moveX (20) moves
the mouse to the right 20 pixels, followed by a 0.1-second pause.
Then the DigiMouse .moveY (20) moves the mouse 20 pixels
down, and so on.

Finally, the functions digitalWrite (1, HIGH) and
digitalWrite(l, LOW) turnthe LED on for 0.25 seconds.



void loop () {
// Choose x and y values from -3 to 3
unsigned int random x = 3 - random(7);
unsigned int random y = 3 - random(7);

// Move the mouse cursor
DigiMouse.moveX (random Xx) ;
DigiMouse.moveY (random y) ;

// Turn on the LED for 0.25 seconds
digitalWrite (1, HIGH)
DigiMouse.delay (250) ;
digitalWrite (1, LOW) ;

// Pause for 5 to 10 seconds
DigiMouse.delay (5000 + random(5000)) ;

Program an infinite scroller

The code below uses DigiMouse.scroll (5) to scroll down
endlessly (or scroll up, depending on your mouse settings). To
change the scroll direction, use the argument -5 instead.

#include <DigiMouse.h>

void setup () {
pinMode (1, OUTPUT) ;
DigiMouse.begin () ;

// Turn on LED for 0.25 seconds
digitalWrite (1, HIGH)
DigiMouse.delay (250) ;
digitalWrite (1, LOW) ;

}

void loop () {
DigiMouse.scroll (5);
//DigiMouse.scroll (-5) ;
DigiMouse.delay (100) ;

}

#include <DigiMouse.h>

void setup () {
pinMode (1, OUTPUT) ;
DigiMouse.begin () ;

}

void loop () {
DigiMouse.delay (2000) ;

DigiMouse.moveX (20) ;
DigiMouse.delay (100) ;

DigiMouse.moveY (20) ;
DigiMouse.delay (100) ;

DigiMouse.moveX (-20) ;
DigiMouse.delay (100) ;

DigiMouse.moveY (-20) ;
DigiMouse.delay (100) ;

// Turn on LED for 0.25 seconds
digitalWrite (1, HIGH) ;
DigiMouse.delay (250) ;
digitalWrite (1, LOW) ;

_] Some useful DigiMouse functions

Function What it does

DigiMouse.begin () ; Initializes the software you'll
use to control your mouse.
Typically included in the
setup() function.

DigiMouse.delay (1000) ; Pauses for 1000 milliseconds
(1 second)

DigiMouse.moveX (20) ; Moves the cursor 20 pixels to

the right




DigiMouse

.moveX (-20) ;

Moves the cursor 20 pixels to
the left

DigiMouse

.moveY (20) ;

Moves the cursor down 20
pixels

DigiMouse

.moveY (-20) ;

Moves the cursor up 20 pixels

DigiMouse

.move (15,-33,0);

Moves the cursor 15 pixels
right and 20 pixels up, and
scrolls zero pixels

DigiMouse.scroll (10); Scrolls down 10 units (or up,
depending on your mouse
preferences)

DigiMouse.scroll (-10) ; Scrolls up 10 units (or down,

depending on your mouse
preferences)

DigiMouse.

leftClick () ;

Presses down the left click
button

DigiMouse.

setButtons (1<<0) ;

Hold down the left click button

DigiMouse.

setButtons (1<<1) ;

Holds down the right click
button

DigiMouse.

setButtons (0) ;

Releases all mouse buttons

DigiMouse.

update () ;

Preserves USB connection if
your mouse jiggler pauses for
more than a couple seconds

_] Some useful Arduino functions

Example function

What it does

pinMode (1, OUTPUT) ;

Configures pin 1 (the red LED) to
behave as an output. You should
include this in your setup ()
function.

digitalWrite(l, HIGH);

Sets pin 1 to "high" voltage,
turning on the red LED light

digitalWrite (1, LOW);

Sets pin 1 to "low" voltage, turning
off the red LED light

random (100) ;

Returns a pseudorandom number
from 0 to 99

random (100, 2500);

Returns a pseudorandom number
from 100 to 2499

_] Program a low-key mouse jiggler

If you want your mouse jiggler's movements to be subtle, you can
write a program like the one below. It chooses random X and Y
values from -3 to 3, then moves the cursor that many pixels. It then
blinks the LED and pauses for a random duration from 5 to 10

seconds.

#include <DigiMouse.h>

void setup () {
DigiMouse.begin () ;
pinMode (1, OUTPUT) ;
}

//Continued on the next page




